C5 Sensor Heater Circuit Malfunction
  • Register
  • Help
Results 1 to 2 of 2
  1. #1
    Fellow Frogger! BallinaOB's Avatar
    Join Date
    Nov 2010
    Location
    Bathurst, Australia
    Posts
    131

    Default C5 Sensor Heater Circuit Malfunction

    Hi all,

    Had the front oxygen sensor on my 2003 C5 petrol 4cyl replaced with a genuine citroen part yesterday as I was advised the new sensor would cure my intermittent anti pollution fault. The fault would mainly occur when it is hot and humid ( which it has become here in Ballina over the last few days).

    Driving the car home the anti pollution light came on. Took the car back this morning and it is giving the fault code "P0135 O2 Sensor Heater Circuit Malfunction (Bank 1 Sensor 1)". The garage are researching the code and getting back to me. Had the fault reset but again, driving the car home the anti pollution light came on.

    Just a few questions for the list:

    Does Bank 1 Sensor 1 refer to the front or rear sensor?

    Advertisement


    Has anyone else had a P0135 which they have fixed?

    Car is still driving very well, no loss of power very smooth acceleration, idle and gear changes.

    Cheers,

    Anthony
    Anthony O'Brien
    2008 C5
    2007 C4
    2004 C5 Estate

    Previous
    2003 C5
    2004 C2 (now with youngest son)
    2006 C2 (now with eldest son)

  2. #2
    1000+ Posts
    Join Date
    Nov 2010
    Location
    Newcastle
    Posts
    2,573

    Default

    Quote Originally Posted by BallinaOB View Post
    Hi all,
    Had the front oxygen sensor on my 2003 C5 petrol 4cyl replaced with a genuine citroen part yesterday as I was advised the new sensor would cure my intermittent anti pollution fault. The fault would mainly occur when it is hot and humid ( which it has become here in Ballina over the last few days).
    Driving the car home the anti pollution light came on. Took the car back this morning and it is giving the fault code "P0135 O2 Sensor Heater Circuit Malfunction (Bank 1 Sensor 1)". The garage are researching the code and getting back to me. Had the fault reset but again, driving the car home the anti pollution light came on.

    Just a few questions for the list:
    Does Bank 1 Sensor 1 refer to the front or rear sensor?
    Has anyone else had a P0135 which they have fixed?
    Car is still driving very well, no loss of power very smooth acceleration, idle and gear changes.
    Cheers,Anthony
    Hi Anthony
    I am no expert however that will not stop me having a say
    I Googled "P0135 O2 Sensor Heater Circuit Malfunction (Bank 1 Sensor 1)" and came up with a lot of discussion on forums. All sorts of makes not just Citroen, so its not uncommon. That may not be helpfull but you could read them for ideas.

    I would check the electrical connections and the fuse to see if there is a high resistance on the heater circuit. It seems it is the first sensor and as you do not have the V8 option it is bank 1 .
    Perhaps it would be wise to check the hoses etc around the engine to see that there are no leaks. The computer sometimes(most times) interperets the data to "estimate" the fault. Those early C5 have a reputation for odd faults.
    Cheers Jaahn

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •