XM Repairs in Northern Melbourne?
  • Register
  • Help
Results 1 to 7 of 7
  1. #1
    Tadpole
    Join Date
    Dec 2011
    Location
    Mill Park
    Posts
    1

    Default XM Repairs in Northern Melbourne?

    Hi All,
    I just moved to Melbourne and during the move I believe my speedo cable broke. I'm guessing it was the speedo cable as that was what needed replacing last time the speedo went dead - that was about 18 months ago. Does anyone know a Citroen specialist/mechanic in the northern suburbs of Melbourne? It's for a '91 XM V6.
    Cheers,
    Luke

    Advertisement

  2. #2
    Member ajm212's Avatar
    Join Date
    May 2011
    Location
    Melbourne
    Posts
    61

    Default

    It's not as north as you might wish, but I take my XM to Citro Motors in Fitzroy. Mel services a number of XMs and his wife used to drive one. To the best of my knowledge, the other Citroen mechanics on the northern side of the city are also pretty much in inner/middle suburbs.

    I think Citro motors closes until the end of January part way through this week, so if you decide you want them to do the work, you should probably talk to Mel pretty quickly.

    Andrew

    CITRO MOTORS
    15 -17 Smith St Fitzroy 3065
    (03) 9419 4537

  3. #3
    UFO
    UFO is offline
    CitroŽn Tragic UFO's Avatar
    Join Date
    Aug 2001
    Location
    Gerringong, NSW, Australia
    Posts
    9,666

    Default

    In the interim if you have a GPS use this as your speedo.
    Craig K
    2009 C5 HDi Exclusive

  4. #4
    Fellow Frogger! sparkey's Avatar
    Join Date
    Apr 2005
    Location
    Melbourne
    Posts
    372

    Default

    Quote Originally Posted by xylophonica View Post
    Hi All,
    I just moved to Melbourne and during the move I believe my speedo cable broke. I'm guessing it was the speedo cable as that was what needed replacing last time the speedo went dead - that was about 18 months ago. Does anyone know a Citroen specialist/mechanic in the northern suburbs of Melbourne? It's for a '91 XM V6.
    Cheers,
    Luke
    A bit closer to home for you is Cars of France (Darebin Tyre and Service Centre) 170 Grange Rd, Fairfield 9499 7522. Nick is the specialist there. I attempted to book in before xmas last year & they were flat strap.
    '73 & '74 GS Break
    '00 Xantia Break
    '78 504 GL - gone to good home
    '69 ID19B - if wasn't for mortgage would still have, '74 DS23 Pallas
    '74 Renault TS , '69 Renault TS - last seen forlorn at Taminda wreckers

  5. #5
    Real cars have hydraulics DoubleChevron's Avatar
    Join Date
    May 2000
    Location
    Ballarat,Vic,Aust.
    Posts
    16,322

    Default

    There isn't a cable is there ?? It'll probably be dry solder joints in the dash. Try giving it a slap or two on top and see if the speedo starts working again. I think the diesel model somehow uses a flywheel sensor for it's speedo (yeah that one has me buggered, it must know what gear the car is in to calculate the speed).

    I'll see if I can find the photos of the XM dash and upload them. They would have been all lost in the crash.

    seeya,
    Shane L.
    'Cit' homepage:
    Citroen Workshop
    Proper cars--
    '85 Series II CX2500 GTi Turbo I
    '63 ID19 http://www.aussiefrogs.com/forum/citro%EBn-forum/90325-best-project-car-you-have-ever-seen.html
    '72 DS21 ie 5spd pallas (last looked at ... about 15years ago)
    '78 GS1220 pallas
    '92 Range Rover Classic ... 5spd manual.

    Yay ... No Slugomatics


    Modern Junk:
    '07 Poogoe 407 HDi 6spd manual

  6. #6
    Fellow Frogger! denxm's Avatar
    Join Date
    Nov 2010
    Location
    uki aust
    Posts
    448

    Default need for speed

    you should check if it is the cable by taking out the instrument panel ,go for a short drive and see -feel if the cable is turning, easy to do
    the plastic connector on end of cable can come loose from speedo also
    if it is the cable it is not too hard to replace yourself, no better or worse than most if you cannot
    get a garage this time of year to do it

  7. #7
    Fellow Frogger! caparobertsan's Avatar
    Join Date
    May 2011
    Location
    SOUTH MORANG
    Posts
    792

    Default Service centre

    So Where did you end up taking your car? Please let me know as I have to take mine too.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •