C4 Owners...
  • Help
Results 1 to 6 of 6

Thread: C4 Owners...

  1. #1
    1000+ Posts Uga Boga's Avatar
    Join Date
    May 2004
    Location
    Melbourne
    Posts
    1,057

    Default C4 Owners...

    I was wondering, do you guys experience the steering wheel rapidly vibrate when braking? Or is it only me??

    Advertisement


    Also, what about this recall - http://www.vosa.gov.uk/vosa/apps/rec...2570C7003B6875 ??
    Last edited by Uga Boga; 13th January 2006 at 02:25 PM.
    407 3.0L Exclusive (2007)

    Expert 2.0L (2009)

    Laguna 2.0L dCi (2007)

  2. #2
    1000+ Posts TroyO's Avatar
    Join Date
    Sep 2002
    Location
    Perth, Western Australia
    Posts
    2,514

    Default

    Quote Originally Posted by Uga Boga
    I was wondering, do you guys experience the steering wheel rapidly vibrate when braking? Or is it only me??
    Warped brake disks perhaps?

    Troy.

  3. #3
    Fellow Frogger! Trixie's Avatar
    Join Date
    Aug 2005
    Location
    Sydney, Australia
    Posts
    495

    Default

    Quote Originally Posted by Uga Boga
    I was wondering, do you guys experience the steering wheel rapidly vibrate when braking? Or is it only me??

    Also, what about this recall - http://www.vosa.gov.uk/vosa/apps/rec...2570C7003B6875 ??
    1000km so far, and no - the pedal feel is sweet and the brakes are beautifully progressive and sharp.

    The Subaru has had this problem however - and did from new; apparently there was too high a Sulphur content in the pads and thus in humid weather deposits form on the rotors leading to shuddering steering and uneven braking etc.

    Seems pretty common with many cars these days unfortunately.

    No word on the recall here. We tend not to repeatedly cause ingress of saline water into any bits of ours of course.
    John

    2005 Renaultsport Clio 182 Cup - French Racing Blue
    2008 BMW 325i M-sport steptronic sedan - Alpineweiss
    2010 BMW 320d Touring Innovations - Space Grey

  4. #4
    jmn
    jmn is offline
    Member
    Join Date
    Mar 2004
    Location
    Mangerton NSW
    Posts
    106

    Default

    I had this problem with an 01 Xsara at around 18,000 k. An aquaintance had the same problem with his Ford XR8. He finished up with a new set of discs under warranty after a few futile attempts to fix it with pads.

    No sign (so far) of this on my C5 with 34,000 k.

    There was a link to an article about this some time ago. The problem seems to be the formation of a compound called cementite under certain conditions. It is very hard to get rid of and in many cases the only fix is disc replacement.

    Good luck with this.

    jm

  5. #5
    Fellow Frogger! Trixie's Avatar
    Join Date
    Aug 2005
    Location
    Sydney, Australia
    Posts
    495

    Default

    Here's an article which is helpful in explaining things:

    http://www.stoptech.com/tech_info/wp...rakedisk.shtml
    John

    2005 Renaultsport Clio 182 Cup - French Racing Blue
    2008 BMW 325i M-sport steptronic sedan - Alpineweiss
    2010 BMW 320d Touring Innovations - Space Grey

  6. #6
    Member sim0n's Avatar
    Join Date
    Jul 2005
    Location
    SYDNEY
    Posts
    88

    Default

    nope, however, the acceleration reaction is very slow on mine...especially from very low speeds or a standstill.....i would depress the accelerator and have 2 seconds before the car actually moves.....

    also, when i brake harder at times, it feels like the car is about to stall when i come to a stop.
    C4 Exclusive 2.0l Blanc Banquise

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •