Anti Theft C4
  • Register
  • Help
Results 1 to 6 of 6

Thread: Anti Theft C4

  1. #1
    Tadpole
    Join Date
    Nov 2005
    Location
    Hobart, Tasmania
    Posts
    2

    Default Anti Theft C4

    Bonjour,

    I have had a C4 for six months and twice now, when I have gone to start it, the screen displays "Anti-Theft Faulty". The engine won't turn over and I have had to be towed to the service centre where they have reset the computer.

    Does any body know why this happens and how to prevent it?

    Fe Fe

    Advertisement

  2. #2
    Member
    Join Date
    Sep 2005
    Location
    Sydney
    Posts
    89

    Default

    Quote Originally Posted by Fe Fe
    Bonjour,

    I have had a C4 for six months and twice now, when I have gone to start it, the screen displays "Anti-Theft Faulty". The engine won't turn over and I have had to be towed to the service centre where they have reset the computer.

    Does any body know why this happens and how to prevent it?

    Fe Fe
    Is it a VTR, VTS or Exclusive?

  3. #3
    Tadpole
    Join Date
    Nov 2005
    Location
    Hobart, Tasmania
    Posts
    2

    Default

    Hi David,

    It's a 1.6 SX

    Fe Fe

  4. #4
    1000+ Posts Uga Boga's Avatar
    Join Date
    May 2004
    Location
    Melbourne
    Posts
    1,057

    Default

    Do you have the alarm option?
    407 3.0L Exclusive (2007)

    Expert 2.0L (2009)

    Laguna 2.0L dCi (2007)

  5. #5
    Member sim0n's Avatar
    Join Date
    Jul 2005
    Location
    SYDNEY
    Posts
    88

    Default

    id say loose cabling.....its always loose cabling or something to do with the computer which "noone can fix"

    ps uga - my fuel consumption is steadily going down lol...im at 11.7 atm and thats driving hard with air con on...i think something wrong with ur c4

    the dealer told me what u said he would...the cars new things are still tight etc...he might just be right in my case
    C4 Exclusive 2.0l Blanc Banquise

  6. #6
    Tadpole ozVTR's Avatar
    Join Date
    Jun 2005
    Location
    Brisbane
    Posts
    21

    Default

    The anti-theft system consists of the transponder, in the key, the interrogator, in the ignition lock and the engine ECU. An intermittent fault (i.e. a bad connection) may shut down the engine ECU but you would think this might happen at random times not just on start up. If it were just a matter of resetting the ECU to get it going, youíd have to think itís a software failure. Considering that other Citroen cars are suffering software bugs I would not be surprised.
    No matter what the fault is, youíd reset the system once (sh!t happens) but NOT twice, thatís a problem!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •