More GS Woes
  • Register
  • Help
Results 1 to 5 of 5

Thread: More GS Woes

  1. #1
    Fellow Frogger!
    Join Date
    Nov 2010
    Location
    Kapunda
    Posts
    448

    Default More GS Woes

    The indicators on my GS have stopped working. Have checked all the bulbs and connections thereto so I reckon it must be the Flasher unit (fuses OK too).But where is it, please help. Also I would love to have a Circuit Diagram, (Not the layout as in Haynes) can someone point me in the right direction?
    Woody

    Advertisement

  2. #2
    1000+ Posts Ken W's Avatar
    Join Date
    Sep 2002
    Location
    North Brisbane
    Posts
    1,888

    Default

    Woody,

    Is this what you are look for?

    Cheers, Ken
    Attached Files Attached Files

  3. #3
    Fellow Frogger!
    Join Date
    Jun 2015
    Location
    Ashburton
    Posts
    182

    Default Usually sits behind the dash in a cit I think.

    At least my ds and gsa are set up that way. Listen for where the click comes from if in doubt

  4. #4
    Fellow Frogger!
    Join Date
    Nov 2010
    Location
    Kapunda
    Posts
    448

    Default

    Thats the problem, it has stopped clicking!
    Woody

  5. #5
    Fellow Frogger!
    Join Date
    Nov 2010
    Location
    Kapunda
    Posts
    448

    Default

    Thanks Ken, thats great.
    Woody

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •