GS Coil
  • Register
  • Help
Results 1 to 14 of 14
Like Tree4Likes
  • 1 Post By andrewj
  • 3 Post By graham66

Thread: GS Coil

  1. #1
    1000+ Posts
    Join Date
    Mar 2003
    Location
    Location Location
    Posts
    1,576

    Default GS Coil

    Hello

    GS '72 1015 is running rough, misfiring and gutless under load. Have noticed the (suppressor?)... not sure what function it serves... the thingie attached to the +ve side... is really hot to touch.

    Never noticed it hot like that before. Could the coil be shagged?

    Surprised to see it's a Lucas, not sure if it's pieces d' originale. Cheers for any info.

    Advertisement


    GS Coil-img_4094.jpgGS Coil-img_4096.jpg

  2. #2
    Administrator GreenBlood's Avatar
    Join Date
    Mar 2001
    Location
    Brisbane
    Posts
    8,193

    Icon3

    Quote Originally Posted by graham66 View Post
    Hello

    GS '72 1015 is running rough, misfiring and gutless under load. Have noticed the (suppressor?)... not sure what function it serves... the thingie attached to the +ve side... is really hot to touch.

    Never noticed it hot like that before. Could the coil be shagged?

    Surprised to see it's a Lucas, not sure if it's pieces d' originale. Cheers for any info.
    That's a ballast coil, and yes the ballast can get very hot = normal

    Not sure if a ballast coil is original to the car though, and doubt a Lucas would be original

    Cheers
    Chris
    74 D(very Special) >>Rejuvenation Thread<<
    08 C5 X7 HDi very Noir



    "Déesse" Roland Barthes, 'Mythologies', 1957

    The Déesse has all the characteristics of one of those objects fallen from another universe that fed the mania for novelty in the eighteenth century and a similar mania expressed by modern science fiction: the Déesse is first and foremost the new Nautilus.

    (Umberto Eco [Ed], The History of Beauty, Rizzoli, NY, 2004)

  3. #3
    Fellow Frogger! andrewj's Avatar
    Join Date
    Jan 2004
    Location
    Margate
    Posts
    385

    Default

    Hi Graham,

    From memory, all the GS's I've got have ballast resistors, so assuming original.

    Obvious suspects are pocketing points and/or the condenser. Is it worse on hot days? I had a condenser that used to pack it in when it got hot, only to come good once it cooled down.

    Cheers,
    Andrew

    Driving - '90 XM, '85 CX IE Auto, 406 Coupe, 405 srdt wagon, '78 dyane, Resting (or Rusting): '73 Birotor '82 CX Presitige, '81 CX Break IE, GS X2, GS1015 Wagon, GS 1300 5sp Wagon, '76 GS 1220 Wagon, '75 GS Wagon, '58 2CV, '58 Vauxhall Velox

  4. #4
    1000+ Posts
    Join Date
    Mar 2003
    Location
    Location Location
    Posts
    1,576

    Default

    Interesting, thanks Chris

  5. #5
    1000+ Posts
    Join Date
    Mar 2003
    Location
    Location Location
    Posts
    1,576

    Default

    Hi Andrew, yeah nah, same all the time, regardless of hot or cold.

    I might change the condenser though, see if that makes any difference.

  6. #6
    Fellow Frogger! andrewj's Avatar
    Join Date
    Jan 2004
    Location
    Margate
    Posts
    385

    Default

    Quote Originally Posted by graham66 View Post
    Hi Andrew, yeah nah, same all the time, regardless of hot or cold.

    I might change the condenser though, see if that makes any difference.
    Ha ha, "Yeah but Nah" - haven't heard that from anyone south of Townsville for many years!

    Driving - '90 XM, '85 CX IE Auto, 406 Coupe, 405 srdt wagon, '78 dyane, Resting (or Rusting): '73 Birotor '82 CX Presitige, '81 CX Break IE, GS X2, GS1015 Wagon, GS 1300 5sp Wagon, '76 GS 1220 Wagon, '75 GS Wagon, '58 2CV, '58 Vauxhall Velox

  7. #7
    1000+ Posts
    Join Date
    Mar 2003
    Location
    Location Location
    Posts
    1,576

    Default

    Andrew just wondering what ign coil is on your 1015.... Ducellier?

  8. #8
    Fellow Frogger! andrewj's Avatar
    Join Date
    Jan 2004
    Location
    Margate
    Posts
    385

    Default

    let me have a look in the morning...

    Driving - '90 XM, '85 CX IE Auto, 406 Coupe, 405 srdt wagon, '78 dyane, Resting (or Rusting): '73 Birotor '82 CX Presitige, '81 CX Break IE, GS X2, GS1015 Wagon, GS 1300 5sp Wagon, '76 GS 1220 Wagon, '75 GS Wagon, '58 2CV, '58 Vauxhall Velox

  9. #9
    Fellow Frogger! andrewj's Avatar
    Join Date
    Jan 2004
    Location
    Margate
    Posts
    385

    Default

    ok - can confirm the 1015 wagon has a ducellier in it. 1220 wagon has a Bosch GT40. Both have ballast resistors.
    GreenBlood likes this.

    Driving - '90 XM, '85 CX IE Auto, 406 Coupe, 405 srdt wagon, '78 dyane, Resting (or Rusting): '73 Birotor '82 CX Presitige, '81 CX Break IE, GS X2, GS1015 Wagon, GS 1300 5sp Wagon, '76 GS 1220 Wagon, '75 GS Wagon, '58 2CV, '58 Vauxhall Velox

  10. #10
    1000+ Posts
    Join Date
    Mar 2003
    Location
    Location Location
    Posts
    1,576

    Default

    Cheers Andrew, thanks

  11. #11
    1000+ Posts
    Join Date
    Mar 2003
    Location
    Location Location
    Posts
    1,576

    Default

    All sorted, it was the points. Cassette type. S.E.V Marchal.

  12. #12
    1000+ Posts Bruce H's Avatar
    Join Date
    Apr 2001
    Location
    Brisbane
    Posts
    1,212

    Default

    Glad to hear it's fixed, Graham.
    Spark plugs were done, then I recently replaced the petrol pump on mine when it wouldn't keep running at all, and then with help from Brian B we tried various known-to-be-working-on-other-cars-distributors when mine was found to be running on 3 or fewer cylinders, eventually going back to the original.
    With fresh fuel and warmed up it ran slightly better, but still runs rough and sometimes backfires when cold.
    Unfortunately, I don't use it often enough to currently justify spending any more time trying to fix it. Tonight it will hopefully transport me to the CCCQ meeting, but I'll be taking my phone and RACQ card just in case
    Bruce H

    Now 99 Xantia SX x2; 96 Xantia SX; 76 GS Club Estate x2; 76 GS Club; 74 GS Club; 88 VW T3 Reimo
    Before: AX Gti; BX 19TRi Estate; CX 2200 Super & Pallas; CX2400 Pallas; CX 2400ie Prestige auto; DS3 DStyle; GS Pallas; GSA Club; Xantia Image Estate; Xantia Exclusive; Xsara VTR R4; 1.4 Special Estate; Virage; R16TS

    Contact for the Australian Citroen GS GSA and Birotor Register http://australiancitroengsgsaandbiro...com/index.html

  13. #13
    1000+ Posts Bruce H's Avatar
    Join Date
    Apr 2001
    Location
    Brisbane
    Posts
    1,212

    Default

    Well that didn't happen! When I tried to get it out of the garage tonight it is back to trying to run on 2 cylinders which, not being a 2CV, it wouldn't do
    Bruce H

    Now 99 Xantia SX x2; 96 Xantia SX; 76 GS Club Estate x2; 76 GS Club; 74 GS Club; 88 VW T3 Reimo
    Before: AX Gti; BX 19TRi Estate; CX 2200 Super & Pallas; CX2400 Pallas; CX 2400ie Prestige auto; DS3 DStyle; GS Pallas; GSA Club; Xantia Image Estate; Xantia Exclusive; Xsara VTR R4; 1.4 Special Estate; Virage; R16TS

    Contact for the Australian Citroen GS GSA and Birotor Register http://australiancitroengsgsaandbiro...com/index.html

  14. #14
    1000+ Posts
    Join Date
    Mar 2003
    Location
    Location Location
    Posts
    1,576

    Default

    Bruce does yours have the cassette type points?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •