Citroen CX Injector pulse...
  • Register
  • Help
Results 1 to 9 of 9
  1. #1
    Tadpole
    Join Date
    Jan 2017
    Location
    Christchurch
    Posts
    4

    Default Citroen CX Injector pulse...

    Hello fellow Citroenistas

    As well as replying to this long running thread Citroen CX injection query I thought I would start a new thread as well! Maximum exposure and all that good stuff!

    I have recently acquired a long sleeping 1979 CX 2400 ie CMatic and am in the process of reviving it. It was stored in a car port for about 15 years and has 54000 miles on it and very little rust! Stored because the car would not select gears, so what could possibly go wrong there!

    I have replaced the plugs, the fuel system (everything from tank forward), had the injectors refurbished and checked everything over (cleaned all the sockets i can find etc).

    There is fuel at the rail (new pump works as it should), there is spark at the plugs but there doesn't seem to be enough pulse at the injectors to fire them (i got a tiny reading on the multimeter but not much).

    So I was wondering what the conclusion to this thread was? Where did you find the problem with the injector pulse?

    Also where is the ECU kept in one of these?

    All help gratefully received!

    cheers
    Red

    ps name should have been "mad as a citroen" but i didn't notice it was too long until it was too late....

    Advertisement

  2. #2
    Fellow Frogger! rmac's Avatar
    Join Date
    Oct 2010
    Location
    Denmark, Western Aust.
    Posts
    750

    Default

    Still not resolved. Have to get back to the auto electrician to follow up another suggestion as to the possible source of the problem. The ECU is in the back of the glovebox - behind the lining.
    Current Cars
    Australia's 2016 C5 2.0HDi Last
    2011 C5 2.0HDi Comfort
    1973 Citroen D Super 5,
    1981 Citroen CX 2400 Pallas C-matic,
    1981 Citroen CX 2400ie Super Familiale C-matic - Raid Arctique 2014
    1991 Mazda E2200
    1924 Citroen 'la petit citron'

  3. #3
    1000+ Posts Ken W's Avatar
    Join Date
    Sep 2002
    Location
    North Brisbane
    Posts
    1,925

    Default

    Red,

    You cannot check an injection pulse with a multimeter, you really need a voltage waveform display like an oscilloscope to see what is going on. Do you have any buddies who are into electronics and have one of these?

    Cheers, Ken

  4. #4
    Real cars have hydraulics DoubleChevron's Avatar
    Join Date
    May 2000
    Location
    Ballarat,Vic,Aust.
    Posts
    16,414

    Default

    I'm not sure about the earlier CX injection (Greg might have some ideas, he's owned his prestige for years). Does it have 12volts at the injectors Have you cleaned the earth point above the battery and any wiring connectors (lift the spare wheel out and any cover under it and pull the wiring connectors apart.... clean/replace connector blocks as required).

    seeya,
    Shane L.
    'Cit' homepage:
    Citroen Workshop
    Proper cars--
    '85 Series II CX2500 GTi Turbo I
    '63 ID19 http://www.aussiefrogs.com/forum/citro%EBn-forum/90325-best-project-car-you-have-ever-seen.html
    '72 DS21 ie 5spd pallas (last looked at ... about 15years ago)
    '78 GS1220 pallas
    '92 Range Rover Classic ... 5spd manual.

    Yay ... No Slugomatics


    Modern Junk:
    '07 Poogoe 407 HDi 6spd manual

  5. #5
    Tadpole
    Join Date
    Jan 2017
    Location
    Christchurch
    Posts
    4

    Default

    Hi rmac, sorry to hear you are still without that CX!

    Hi chaps

    Well the multimeter reacted while i was testing it so i assumed that it was pulsing and that the meter would not react quick enough to the change in voltage. Whatever it was doing wasn't a big enough bang to actually actuate the injectors.

    Sadly I dont have a friend with such equipment to hand, although Ill ask about as I work for a TV/radio broadcast company and there is bound to that kit floating about at work!

    I have cleaned the earth and all connectors i can find, ill dig out the ecu now i know where it and check those connectors and then go through all the rest again.

    I am assuming 12v at the injector, its not that sophisticated but then whatever it is it isn't there so back to poking about this week!

    Ill update if i find anything useful!

    Thanks for the comments.. viva la citroen!

    cheers
    Red

  6. #6
    1000+ Posts Greg C's Avatar
    Join Date
    Oct 2003
    Location
    Sydney
    Posts
    1,304

    Default

    Quote Originally Posted by rmac View Post
    Still not resolved. Have to get back to the auto electrician to follow up another suggestion as to the possible source of the problem. The ECU is in the back of the glovebox - behind the lining.
    No, the ECU is behind the foot pedals. Very unlikely to be the cause of the problem. As in the other thread, check the ignition system thoroughly. Then clean the throttle position switch and make sure all air hoses are good
    Mine

    CX Prestige
    Toyota Prius

    In the family

    Xantia SX

  7. #7
    Fellow Frogger! rmac's Avatar
    Join Date
    Oct 2010
    Location
    Denmark, Western Aust.
    Posts
    750

    Default

    Quote Originally Posted by Greg C View Post
    No, the ECU is behind the foot pedals. Very unlikely to be the cause of the problem. As in the other thread, check the ignition system thoroughly. Then clean the throttle position switch and make sure all air hoses are good
    That's interesting as in "Pascale" it is in the glovebox behind the lining.

    The auto electricians (plural) have been over the wiring and components as we have located them. The last suggestion was to check a component located beneath the coil. (GregC - ignition module)
    Last edited by rmac; 23rd January 2017 at 02:16 PM.
    Current Cars
    Australia's 2016 C5 2.0HDi Last
    2011 C5 2.0HDi Comfort
    1973 Citroen D Super 5,
    1981 Citroen CX 2400 Pallas C-matic,
    1981 Citroen CX 2400ie Super Familiale C-matic - Raid Arctique 2014
    1991 Mazda E2200
    1924 Citroen 'la petit citron'

  8. #8
    1000+ Posts Greg C's Avatar
    Join Date
    Oct 2003
    Location
    Sydney
    Posts
    1,304

    Default

    Is Pascale a 2500? If so that is the ignition computer.
    Mine

    CX Prestige
    Toyota Prius

    In the family

    Xantia SX

  9. #9
    Fellow Frogger! rmac's Avatar
    Join Date
    Oct 2010
    Location
    Denmark, Western Aust.
    Posts
    750

    Default

    It is a 2400 ie transplanted from a Prestige into the Familiale.
    Current Cars
    Australia's 2016 C5 2.0HDi Last
    2011 C5 2.0HDi Comfort
    1973 Citroen D Super 5,
    1981 Citroen CX 2400 Pallas C-matic,
    1981 Citroen CX 2400ie Super Familiale C-matic - Raid Arctique 2014
    1991 Mazda E2200
    1924 Citroen 'la petit citron'

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •