CX 25GTI Auto wont start
  • Register
  • Help
Results 1 to 8 of 8
Like Tree3Likes
  • 1 Post By Balki
  • 1 Post By gerrypro
  • 1 Post By DoubleChevron

Thread: CX 25GTI Auto wont start

  1. #1
    Tadpole
    Join Date
    Mar 2015
    Location
    United Kingdom
    Posts
    13

    Default CX 25GTI Auto wont start

    Hello.
    Anyone got a pointer towards what is wrong please.
    Three weeks ago I went a really good brisk run with the CX. No problems and very enjoyable. Came to start it yesterday first time since that run. Engine spins over fine, all I am getting is popping and banging in the exhaust. Nearly fires into life but will not quite make it.
    Any suggestions please.
    Thanks
    JohnT

    Advertisement

  2. #2
    Fellow Frogger! Balki's Avatar
    Join Date
    Nov 2010
    Location
    Sheffield/Tasmania
    Posts
    625

    Default

    fuel preassure
    johnmowcop likes this.
    2016 Cactus
    2003 Range rover l322
    1974 D special
    1971 D special
    1992 CX TGE Safari
    1961 ID19
    1972 DS21 Safari
    1965 Renault R4
    1923 Citroen B2
    1927 B14
    Massey ferguson 550

  3. #3
    Tadpole
    Join Date
    Mar 2015
    Location
    United Kingdom
    Posts
    13

    Default

    Thanks Balki.

    Been having a sniff around other forums. Seems likely one of the following:
    Something called a "big Blue" fuel relay.
    Connection in right and side front footwell.
    Connection at pump or pump itself.
    Do you have any thoughts on these please.
    JohnT

  4. #4
    1000+ Posts gerrypro's Avatar
    Join Date
    Nov 2010
    Location
    Camperdown 3260 Australia
    Posts
    3,067

    Default

    As Far As I Know, Shane carries a spare timing sensor around with him just for cases like this. It seems that they fail without warning!
    johnmowcop likes this.
    Cheers Gerry

  5. #5
    Real cars have hydraulics DoubleChevron's Avatar
    Join Date
    May 2000
    Location
    Ballarat,Vic,Aust.
    Posts
    16,421

    Default

    What year is the CX

    Have a look at see if the intake hose is off. Does the fuel pump cycle on/off when you turn the key. Can you hear the fuel pump buzzing when you crank the engine Do you have power to the coils, power to the injectors .... flywheels sensors usually go heat sensitive, so work when the engine is cold.

    seeya,
    Shane L.
    johnmowcop likes this.
    'Cit' homepage:
    Citroen Workshop
    Proper cars--
    '85 Series II CX2500 GTi Turbo I
    '63 ID19 http://www.aussiefrogs.com/forum/citro%EBn-forum/90325-best-project-car-you-have-ever-seen.html
    '72 DS21 ie 5spd pallas (last looked at ... about 15years ago)
    '78 GS1220 pallas
    '92 Range Rover Classic ... 5spd manual.

    Yay ... No Slugomatics


    Modern Junk:
    '07 Poogoe 407 HDi 6spd manual

  6. #6
    UFO
    UFO is offline
    CitroŽn Tragic UFO's Avatar
    Join Date
    Aug 2001
    Location
    Gerringong, NSW, Australia
    Posts
    9,721

    Default

    Quote Originally Posted by johnmowcop View Post
    Thanks Balki.

    Been having a sniff around other forums. Seems likely one of the following:
    Something called a "big Blue" fuel relay.
    Connection in right and side front footwell.
    Connection at pump or pump itself.
    Do you have any thoughts on these please.
    JohnT
    "Big Blue" is usually near the battery and is quite a large relay, remarkably, coloured blue. A gentle tap may wake it up enough to work for a while - or not. Some will tell you that it is no longer available, but there IS a Bosch equivalent; Have a read of THIS THREAD from years ago for the part number and more info.
    Craig K
    2009 C5 HDi Exclusive

  7. #7
    UFO
    UFO is offline
    CitroŽn Tragic UFO's Avatar
    Join Date
    Aug 2001
    Location
    Gerringong, NSW, Australia
    Posts
    9,721

    Default

    BTW - the Bosch relay is black.
    Craig K
    2009 C5 HDi Exclusive

  8. #8
    Real cars have hydraulics DoubleChevron's Avatar
    Join Date
    May 2000
    Location
    Ballarat,Vic,Aust.
    Posts
    16,421

    Default

    Quote Originally Posted by UFO View Post
    "Big Blue" is usually near the battery and is quite a large relay, remarkably, coloured blue. A gentle tap may wake it up enough to work for a while - or not. Some will tell you that it is no longer available, but there IS a Bosch equivalent; Have a read of THIS THREAD from years ago for the part number and more info.
    The relays and computers move around dependent on year or model. I've found the tachometric relay doesn't so much die, as the wiring plug onto it becomes intermittent The tachometric relay is under the front right headlight in mine. I think some have it inside the cabin!

    seeya,
    Shane L.
    'Cit' homepage:
    Citroen Workshop
    Proper cars--
    '85 Series II CX2500 GTi Turbo I
    '63 ID19 http://www.aussiefrogs.com/forum/showthread.php?t=90325
    '72 DS21 ie 5spd pallas (last looked at ... about 15years ago)
    '78 GS1220 pallas
    '92 Range Rover Classic ... 5spd manual.

    Yay ... No Slugomatics


    Modern Junk:
    '07 Poogoe 407 HDi 6spd manual

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •