My Cx gti t2 and idle problems
  • Register
  • Help
Results 1 to 16 of 16
Like Tree4Likes
  • 1 Post By Greg C
  • 1 Post By thepor
  • 2 Post By JohnW

Thread: My Cx gti t2 and idle problems

  1. #1
    Tadpole
    Join Date
    Aug 2015
    Location
    uk
    Posts
    12

    Default My Cx gti t2 and idle problems

    Hy Everibody


    Hy

    Advertisement


    I have a cx gti t2 that only starts after 10 times and there is no idle at all, the car only runs around 2.500rpm as if I relieve some of the gas, can not maintain the idle speed and the engine goes off immediately! can anyone help me please ???!!!! Many thanks

  2. #2
    1000+ Posts Greg C's Avatar
    Join Date
    Oct 2003
    Location
    Sydney
    Posts
    1,304

    Default

    First thing to check is the air feed into the engine. There must be no leaks after the air flow meter. First suspect would be the bellows, make sure there are no cracks.
    UFO likes this.
    Mine

    CX Prestige
    Toyota Prius

    In the family

    Xantia SX

  3. #3
    Real cars have hydraulics DoubleChevron's Avatar
    Join Date
    May 2000
    Location
    Ballarat,Vic,Aust.
    Posts
    16,424

    Default

    Yes, I think the turbo II has a different injection system. The turbo 1 (and earlier cars) would idle with leaks downstream of the air flow meter, but die instantly as soon as you opened the throttle (ie: flicked the idle switch off on the throttle spindle).

    You will need to check the intercooler and pipe work down around it. The intercooler could well be a rotten piece of junk if the car has lived in the UK for any length of time

    seeya,
    Shane L.
    'Cit' homepage:
    Citroen Workshop
    Proper cars--
    '85 Series II CX2500 GTi Turbo I
    '63 ID19 http://www.aussiefrogs.com/forum/citro%EBn-forum/90325-best-project-car-you-have-ever-seen.html
    '72 DS21 ie 5spd pallas (last looked at ... about 15years ago)
    '78 GS1220 pallas
    '92 Range Rover Classic ... 5spd manual.

    Yay ... No Slugomatics


    Modern Junk:
    '07 Poogoe 407 HDi 6spd manual

  4. #4
    1000+ Posts Greg C's Avatar
    Join Date
    Oct 2003
    Location
    Sydney
    Posts
    1,304

    Default

    Probably dirty contact on the throttle switch too
    Mine

    CX Prestige
    Toyota Prius

    In the family

    Xantia SX

  5. #5
    Tadpole
    Join Date
    Aug 2015
    Location
    uk
    Posts
    12

    Default

    Ok many thanks for the tips, yes it is a Uk car , but when i bought it in 2014 was working perfect although doesnīt as been on the road for quite a long time; i am repairing it in bodywork as it as rust all around specially in the edges (sills and back>) and i need to start it some times, but i suspect more of the intercooler as once when i try to lift the car with a jack to lie down in ramps, the the car fell off the jack and since this situation hasnīt have idle.

    cheers

    peters

  6. #6
    Tadpole
    Join Date
    Aug 2015
    Location
    uk
    Posts
    12

    Default

    Hy

    Many thanks for your clue. Can you explain me what do mean by the bellows, as i live in the Uk but i am not British.

    regards

    Peters

  7. #7
    Tadpole
    Join Date
    Aug 2015
    Location
    uk
    Posts
    12

    Default

    Many thanks for your help

    regards

    peters

  8. #8
    Tadpole
    Join Date
    Aug 2015
    Location
    uk
    Posts
    12

    Default

    Ok many thanks for your help and for the tip .

    regards

    peters

  9. #9
    Tadpole
    Join Date
    Aug 2015
    Location
    uk
    Posts
    12

    Default

    Ok many thanks for your tip, probably it will be that and intercooler problems i mean pipes

    regards

  10. #10
    Tadpole
    Join Date
    Aug 2015
    Location
    uk
    Posts
    12

    Default hy again

    just one more thing ; how do i check for intercooler leaks , there is any special tool or anything that could help me to check it?

    many thanks

    Peters

  11. #11
    Fellow Frogger! marc61's Avatar
    Join Date
    Jul 2013
    Location
    Stamford, UK
    Posts
    331

    Default

    Sounds like a major air leak to me.
    Check the big rubber hose that fits onto the turbo inlet to see if it's done up tight and if it's got any splits or holes in it.
    Check the big hoses that connect to the two ends of the intercooler for splits or loose clips.
    If they're all ok, check all of the smaller air hoses on and around the engine, make sure they are all done up tight and there are no splits or leaks anywhere.

    Cheers

    Marc
    Cheers, Marc.

    1987 CX GTi T2 Maikonics
    1972 SM 2.7 carb
    1972 DS21 EFI

  12. #12
    Tadpole
    Join Date
    Aug 2015
    Location
    uk
    Posts
    12

    Default

    hy Marc

    Many thanks for your tips they are going to be very useful; in fact all this star when i was trying put the car in a ramps and suddenly it falls down the jack and the intercooler big pipe come out from the intercooler; anyway i put the pipe back in place but the car never has idle since that issue and also with the other problems; just one more thing to check all this leaks do you suggested for example water with soap?..
    once again many thanks for your help and all the best for your

    Peters

  13. #13
    1000+ Posts Greg C's Avatar
    Join Date
    Oct 2003
    Location
    Sydney
    Posts
    1,304

    Default

    That's what the factory manual says. Soapy water and compressed air. Good luck


    Sent from my iPhone using Tapatalk
    Mine

    CX Prestige
    Toyota Prius

    In the family

    Xantia SX

  14. #14
    Fellow Frogger! marc61's Avatar
    Join Date
    Jul 2013
    Location
    Stamford, UK
    Posts
    331

    Default

    Quote Originally Posted by thepor View Post
    hy Marc

    Many thanks for your tips they are going to be very useful; in fact all this star when i was trying put the car in a ramps and suddenly it falls down the jack and the intercooler big pipe come out from the intercooler; anyway i put the pipe back in place but the car never has idle since that issue and also with the other problems; just one more thing to check all this leaks do you suggested for example water with soap?..
    once again many thanks for your help and all the best for your

    Peters
    On mine I've had the big diameter hoses blown off, either because they weren't done up tight or the jubilee clip wasn't fitted correctly - usually at the turbo inlet or at the entry to the inlet manifold. In that case there's no chance of idling.

    I also discovered that the entry hose to the intercooler was cracked near the clip due to fatigue. That was the source of bad idling for me.

    I've heard the big concertina hose near the air filter can leak, again I would think that's due to ageing cracks.

    I'd check all the big hoses and their clips first. Then the clips on all the small diameter hoses on and near the engine. It'd also be worth taking the crankcase breather off the back of the engine and checking it's clean and its hose is clean.

    Cheers

    Marc
    Cheers, Marc.

    1987 CX GTi T2 Maikonics
    1972 SM 2.7 carb
    1972 DS21 EFI

  15. #15
    Tadpole
    Join Date
    Aug 2015
    Location
    uk
    Posts
    12

    Default

    Hy everybody

    For this i would like to tanks to all the good people that helps me to sort the idle problem of my cx gti t2. In fact was the second big pipe in the other end that connects the intercooler was a bit loosen from the right place . Many thanks again to everibody and my God save all the cx in the World. Rui Peters
    UFO likes this.

  16. #16
    Too many posts! JohnW's Avatar
    Join Date
    Jul 2001
    Location
    Perth, WA, Australia
    Posts
    10,800

    Default

    Quote Originally Posted by thepor View Post
    Hy everybody

    For this i would like to tanks to all the good people that helps me to sort the idle problem of my cx gti t2. In fact was the second big pipe in the other end that connects the intercooler was a bit loosen from the right place . Many thanks again to everibody and my God save all the cx in the World. Rui Peters
    My CX also hopes that there is divine help! It is a model that has not so many supporters, but as they get older, perhaps more people will appreciate them. I hope so. I am driving mine at present and it is so good.

    I am glad you found your problem.
    Jinandfonic and CXVingtCinq like this.
    JohnW

    Renault 4CV 1951
    Renault R8 1965
    Renault Scenic 2005 (wife's)
    Renault Scenic 2007 (mine)
    Renault Scenic 2006 (daughter's)
    CitroŽn CX Pallas 1980

    National Co-ordinator, Renault 4CV Register of Australia

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •