Antipollution and Surging. Related?
  • Help
Results 1 to 3 of 3
  1. #1
    Member dbol's Avatar
    Join Date
    Mar 2015
    Location
    Brisbane
    Posts
    50

    Default Antipollution and Surging. Related?

    Hello guys,

    My citroen xsara vts has recently produced the antipollution fault code. It also seems to 'surge' or brake slightly in a 1-2 second cycle when I'm decelerating, typically at lower RPM. I would almost describe it as the vehicle engine braking in a pulsing fashion. It seems to disappear as soon as I apply any pressure to the accelerator. Could the antipollution fault be related to this somehow?

    Advertisement

  2. #2
    Member
    Join Date
    Mar 2015
    Location
    Kingscliff NSW Australia
    Posts
    61

    Default

    Hi dbol,

    My Citroen C5 Petrol 16v also has the antipollution fault code come up quite often. I use to get the code cleared at my local garage.
    Now I have found if I unplug and replug the electrical plug joint that goes to the coil pack (under the plastic cover top of motor).
    It resets and clears the fault code.
    I`m not sure if a xsara has the same setup. or even if your car is a petrol.
    The more technical guys on this site will be able to give better advice I`m sure.
    good luck

    Keith

  3. #3
    1000+ Posts Greg C's Avatar
    Join Date
    Oct 2003
    Location
    Sydney
    Posts
    1,304

    Default

    Get the faults read with a Lexia. Then you will be able to work out what is causing the problem. My first guess would be the oxygen sensor but there are plenty of other things that could cause this. The Lexia will help narrow things down
    Mine

    CX Prestige
    Toyota Prius

    In the family

    Xantia SX

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •