Citroen C4 misfiring.
  • Register
  • Help
Results 1 to 5 of 5
  1. #1
    Tadpole Louisb's Avatar
    Join Date
    Jan 2013
    Location
    Melbourne
    Posts
    8

    Default Citroen C4 misfiring.

    Hello/evening/morning everyone.

    Avid reader of the forum, first post however.

    After not being driven for a few weeks, I borrowed my mums C4 (2007, 1.6 Petrol SX, 65,000km) over the weekend to run errands/take for a spin, however, crawling around looking for parking in an underground carpark the vehicle began shaking heavily (air con on full) with anti-pollutant fault on centre screen and engine light flashing/beeping on taco, pulled to the side, ignition off, on again, starts fine and quickly.

    5 meters further the car shakes -misfires- again and engine seizes and unable to start, lights flashing faults on screen again. The RACV mechanic checked diagnostics with nothing found, The car was running on two cylinders when restarted. Just before the incident the vehicle had some slight delays downshifting from second into first (hot weather AL4 behaviour i suspect). Car was towed to local pug dealer.

    Any ideas? Spark plugs, coil pack, injector maybe?

    Last minor service was 9000km ago (5/6 months ago at dealer)
    Drive belt replaced 2 months ago at dealer
    5w40 total oil/filter change 3 weeks ago at citroen garage


    Cheers


    On the plus side, the activation of the power steering pump is a great feature for pushing the car in neutral

    Advertisement
    Last edited by Louisb; 22nd December 2014 at 12:42 AM.

  2. #2
    Contented Peugeot Driver addo's Avatar
    Join Date
    Jun 2005
    Location
    Don't remind me!
    Posts
    16,609

    Default

    Could be coils, don't keep driving it without resolution as the ECU internals can get overstressed powering a failed coil pack.

  3. #3
    1000+ Posts
    Join Date
    Nov 2010
    Location
    Newcastle
    Posts
    2,573

    Default

    Hi,
    I would be checking the fuel filter and the fuel. Water perhaps ? Crap fuel ? Check there before replacing the hardware particularly if there were no faults showing.
    Good luck Jaahn

  4. #4
    Tadpole Louisb's Avatar
    Join Date
    Jan 2013
    Location
    Melbourne
    Posts
    8

    Default

    Hey guys, thanks for your help

    I wouldn't say it's fuel related as the last fill was about 250km ago of V-power from a busy Melbourne shell and the cars been fine all weekend. regarding the fuel filter, last year after a disappointing service from a well known -unnamed- french car mechanic the fuel filter was replaced and literally detached of the fuel pipe a week later causing the engine to stall, spill large amounts with strong odours in peak hour making the car not drivable. The fuel filter has been cable tied to the fuel pipe since the incident, if it was a fuel or filter related problem i would expect an odour and spill under the rear seats maybe, any ideas?

    Thanks, Louis
    Last edited by Louisb; 22nd December 2014 at 01:50 PM.

  5. #5
    1000+ Posts
    Join Date
    Nov 2010
    Location
    Newcastle
    Posts
    2,573

    Default

    Quote Originally Posted by Louisb View Post
    Hey guys, thanks for your help
    I wouldn't say it's fuel related as the last fill was about 250km ago of V-power from a busy Melbourne shell and the cars been fine all weekend. regarding the fuel filter, last year after a disappointing service from a well known -unnamed- french car mechanic the fuel filter was replaced and literally detached of the fuel pipe a week later causing the engine to stall, spill large amounts with strong odours in peak hour making the car not drivable. The fuel filter has been cable tied to the fuel pipe since the incident, if it was a fuel or filter related problem i would expect an odour and spill under the rear seats maybe, any ideas?
    Thanks, Louis
    Hi Louis,
    Now remember we are all just guessing with very little to go on.

    I would still be checking the fuel and the filter first. I have never seen a filter fall off so that's a first. But that is not what I meant, I would check what is in it ! After all if it was bad fuel with some water or crap in it, the filter fills up because that is what it is supposed to do, but it's getting clogged as it does so. At some point it will not let any fuel through. That's the possibility I was thinking of. Stopping and then restarting OK and going well for a while is classic water in fuel from my experience.

    Twice I have had a car of mine stop because of these sort of problems, in past years. Once, some sort of black grainy dirt I guess, that could be shaken out of the filter, possibly a quarter of a cup of it The second time it was water. I had to actually clean the tank that time. Rusty dirty water too. Might have been half a liter in the filter and tank. But the car did keep going and stopping for a week.

    Of course it could not be this. Could be a number of things. The way a mechanic works is to have an educated guess then test. Evaluate the result and repeat process as indicated by the test.
    Jaahn
    Last edited by jaahn; 22nd December 2014 at 10:40 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •