Odd Speedo Behavior
  • Register
  • Help
Results 1 to 3 of 3
  1. #1
    Fellow Frogger! ds21bvh's Avatar
    Join Date
    Nov 2010
    Location
    Brisbane
    Posts
    691

    Default Odd Speedo Behavior

    Hoping someone can point me to the obvious.

    On my 69 DS21 bvh the needle jumps up off zero violently when starting off, and then optimistically reads the speed probably 20 mph too high.

    New cable both sections and all is as it should be the gearbox end... could this be a sticking cable or similar...?

    Advertisement


    Many thanks in advance,

    Mark...

  2. #2
    VIP Sponsor richo's Avatar
    Join Date
    Jan 2006
    Location
    Hobart, the other planet
    Posts
    1,445

    Default

    Quote Originally Posted by ds21bvh View Post
    Hoping someone can point me to the obvious.

    On my 69 DS21 bvh the needle jumps up off zero violently when starting off, and then optimistically reads the speed probably 20 mph too high.

    New cable both sections and all is as it should be the gearbox end... could this be a sticking cable or similar...?

    Many thanks in advance,

    Mark...

    Requires servicing and calibration.
    Relationship of speed cup and needle is likely incorrect...
    Instruments need servicing from time to time, not just cables ;-)

  3. #3
    Fellow Frogger! ds21bvh's Avatar
    Join Date
    Nov 2010
    Location
    Brisbane
    Posts
    691

    Default

    Hi Richo,

    Why did I know you would reply to this...?

    Tightened the cable and all seems well again - though still overly optomistic in speed... I think I will have to send it away - any recommendations...?

    Cheers,

    Mark...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •