Citroen c5 2004 blower fan doesnt work
  • Help
Results 1 to 5 of 5
  1. #1
    Member
    Join Date
    Mar 2013
    Location
    israel
    Posts
    71

    Default Citroen c5 2004 blower fan doesnt work

    A year ago i replaced myself the fan resistor. Today i have didferent symptoms: the eco light is fone and the ac compressor kick in ( by rpm and load) the fan indicators work and can be increased and decreaed. But the fan itself doesnt blow at all...... Could it be the resistor again? Or is it the motor blower itself ? Where can i locate the motor blower itself? I want to add that the 40 amp fuse was burned and i replaced him.

    Advertisement


    Thank you all experts

  2. #2
    Contented Peugeot Driver addo's Avatar
    Join Date
    Jun 2005
    Location
    Don't remind me!
    Posts
    16,609

    Default

    You have replaced the cabin filter (pollen filter) recently?

    It is possible either the motor is partly burned out or the carbon brushes are worn badly. I've not taken one apart but from outside they look very similar to the CitroŽn Xantia fan, so that's why I suggest brushes.

  3. #3
    Member
    Join Date
    Mar 2013
    Location
    israel
    Posts
    71

    Default

    How do i find the motor itself?

  4. #4
    1000+ Posts Ken W's Avatar
    Join Date
    Sep 2002
    Location
    North Brisbane
    Posts
    2,080

    Default

    Here are some photos of pages from the C5 haynes manual that talk about gettting to the fan. These relate to a right hand drive car though.

    Cheers,

    Ken W
    Attached Files Attached Files

  5. #5
    Member
    Join Date
    Mar 2013
    Location
    israel
    Posts
    71

    Default

    thanks a lot pal

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •