03 C5 AL4 more woes.
  • Help
Results 1 to 4 of 4
  1. #1
    Fellow Frogger!
    Join Date
    Jan 2011
    Location
    adelaide
    Posts
    154

    Default 03 C5 AL4 more woes.

    Replaced AL4 2.5 years ago, travelled 9,000 kl.gearbox refusing to change and when it does slips constantly. Using manual mode changes fine. Warranty was 12 months, so looks like a new box or maybe a match.

    Advertisement

  2. #2
    Fellow Frogger
    Join Date
    Jan 2004
    Location
    Sydney
    Posts
    10,192

    Default

    Not necessarily. If it works OK in manual mode, then the clutch packs, bands and pump are presumably still OK and you might avoid having to remove it. Maybe a valve block or electrical problem? Have the fault codes read as a first step.

    Has it been through a puddle? Sometimes, they can take in water through the breather with odd results. Changing the fluid a couple of times often fixes that.

  3. #3
    Fellow Frogger!
    Join Date
    Jan 2011
    Location
    adelaide
    Posts
    154

    Default

    Been out in first lot of rain for a while, but no deep water (over 2cm). Will read the codes and see what they say. Told that the newer AL4 was much better than the original, 96,00 klm. versus 6,000 klm. does not seem to prove this theory.

  4. #4
    Fellow Frogger!
    Join Date
    Feb 2011
    Location
    brisbane Au
    Posts
    940

    Default

    Quote Originally Posted by tazzy View Post
    Replaced AL4 2.5 years ago, travelled 9,000 kl.gearbox refusing to change and when it does slips constantly. Using manual mode changes fine. Warranty was 12 months, so looks like a new box or maybe a match.
    This answer might be a bit late but is your gearbox fixed yet? if not, I would check or replace the output speed sensor. Which would explain why it's a dud in auto mode. Sequential shift bypasses it. Seen the same complaint a couple of times and the diagnostic tool appears to be incapable of picking up a fault in this situation. Worth a try.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •